--> -->

vue

 

 

1.Manually select features 옵션을 기준으로 프로젝트 설치

 


 

 

 다음 이미지 기준을  따라서 설치

 

 

 

1) 터미널에서 다음 명령어로 프로젝트 생성

vue create 프로젝트이름

 

2)설치 옵션에서 Manually select features 를 선택

3) Choose Vue version, Babel, Router , Vuex , Linter/Formatter 

 

4)vue 버전 3.x 선택

 

5) Vue-Router 에서 history 모드를 사용할 것인지에 대해 'Y" 를 입력 후 엔터

 

6) ESLint with error prevention only 를 선택

basic 을 선택하지 않고 stand 를 선택하면 오류검사가 엄격해져서  space ,tab 등 으로 오류 검출이 됨.

 

7)Lint On Save 선택

(앞서 선택한 features 인 Babel, EsLint 등에 대한 설정 옵션 파일을 별도의 config 파일로 만들지 package.json 파일 안에

만들지에 대한 옵션)

 

8) In Package.json 을 선택

마지막 옵션은 앞에서 선택한 옵션을 저장해서 향후 vue 프로젝트를 생성할 때 앞서 선택한 옵션과

동일하게 프로젝트를 빠르게 생성할 수 있도록 preset 을 저장할 수 있는 옵션

 

9) preest 입력

 

 

* vue create 의 Manually select features 설정으로 설치시 오류 해결

1. 방법1    package.json을  6.x 버전으로 깔려 있으면

"eslint": "^5.16.0" 으로 변경 하여 저장한 후 npm install 로 eslint를 다시 설치

 

2. 방법2  [Vue.js] Eslint + Prettier 오류

 

 

*VS Code - Beautify 설치 및 단축키 설정, 코드 정렬 플러그인 설치

 

https://jenny-daru.tistory.com/37

 

 

 

 

 

2. Vue 프로젝트 매니저로 프로젝트 설치

 

1.

 

2

 

3

 

 

 

4.

 

 

5.

 

 

6.

 

 

 

7.

 

8

 

 

 

9.

 

 

 

 

10.

 

 

11.

 

 

 

 

 

 

 

 

 

 

about author

PHRASE

Level 60  라이트

가장 큰 고통은 남에게 말할 수 없는 고통이다. -유태격언

댓글 ( 0)

댓글 남기기

작성